Infrastructure maintenance

Scheduled for May 12, 22:00 PDT  -  May 13, 02:00 PDT

Update

The maintenance date has been changed.
Posted Apr 15, 2025 - 02:08 PDT

Scheduled

Please note that the maintenance date has been changed!

System components will be undergoing scheduled maintenance from May 12, 10 pm to May 13, 2 am PDT to improve reliability and performance.

During this time, there may be short periods of unavailability/instability.

We apologize for any inconvenience. Please contact your account manager or Xsolla support if you have questions or concerns.
Posted Apr 15, 2025 - 01:57 PDT
This scheduled maintenance affects: Pay Station, Store, Login, Launcher, Site Builder, Xsolla.com, Partner Network (Tracking API, Proxy Page), and Services (API, Publisher Account, Documentation).