Xsolla Store Issue
Incident Report for Xsolla
Resolved
We can confirm that the issue is fully resolved.

We apologize for the impact and thank you for your patience.
Posted Jan 30, 2025 - 01:42 PST
Update
All the functionality is operational since 0:04 PST. We'll monitor the services for the next 30 minutes to ensure stability and will post another update.
Posted Jan 30, 2025 - 00:50 PST
Update
There are issues with processing and delivering orders
Posted Jan 30, 2025 - 00:04 PST
Monitoring
We have been working to resolve the issue and are currently monitoring the system's performance.
Posted Jan 29, 2025 - 23:29 PST
Identified
There is degradation in the store.xsolla.com high response time, and unavailability of some methods.
Posted Jan 29, 2025 - 23:00 PST
This incident affected: Store.