Payment Processing Issue
Incident Report for xsolla
Resolved
We had temporary technical issues from a 11/3/2020 04:15 PM PST to 5:14 PM PST. All services are fully operational now. We apologize for the inconvenience!
Posted Nov 03, 2020 - 17:31 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 03, 2020 - 17:09 PST
This incident affected: Pay Station.