Publisher Account Issue
Incident Report for Xsolla
Resolved
This incident has been resolved. We apologize for the inconvenience!
Posted 10 months ago. Dec 31, 2018 - 01:10 PST
Investigating
We have technical issues with Publisher Account https://publisher.xsolla.com
Posted 10 months ago. Dec 31, 2018 - 00:40 PST
This incident affected: Services (Publisher Account).