Payment Processing Issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 24, 2019 - 12:14 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 months ago. Jun 24, 2019 - 11:38 PDT
Investigating
We're experiencing a partial outage due to issues with payment processing.
Posted about 2 months ago. Jun 24, 2019 - 11:25 PDT
This incident affected: Pay Station.