Network issue
Incident Report for xsolla
Resolved
This incident has been resolved.
Posted Aug 30, 2020 - 08:24 PDT
Identified
There are problems with the global internet service. As a result, the response time of our services may increase.
Posted Aug 30, 2020 - 05:14 PDT
Investigating
We are currently investigating this issue.
Posted Aug 30, 2020 - 04:11 PDT
This incident affected: Pay Station, Store and Services (API).