Payment Processing Issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 04:59 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2020 - 04:03 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 04, 2020 - 04:03 PST
Investigating
We are currently investigating this issue.
Posted Mar 04, 2020 - 03:44 PST
This incident affected: Pay Station and Services (API).