Xsolla Secure API Issue
Incident Report for Xsolla
Resolved
We can confirm that the issue is now resolved.

It affected a significant percentage of users from 2024-11-07 21:44:14 PST till 2024-11-07 22:22:14 PST. During that time, users might have experienced delays in payment processing.

We apologize for the impact and thank you for your patience.
Posted Nov 07, 2024 - 22:50 PST
Monitoring
The issue has been identified and the fix has been implemented. We're monitoring the situation.
Posted Nov 07, 2024 - 22:32 PST
Update
We're continuing to investigate the issue with Xsolla Secure API. Partners may experience difficulties with payment processing. We apologize for the inconvenience.
Posted Nov 07, 2024 - 22:12 PST
Investigating
We're experiencing technical issues with Xsolla Secure API. We're investigating the issue.
Posted Nov 07, 2024 - 22:03 PST
This incident affected: Pay Station, Store and Services (API).