Partial degradation of Xsolla services
Incident Report for Xsolla
Resolved
We can confirm that the issue is now resolved.

The main reason of the incident is connectivity issues between network providers in the US west coast region from 02:05 AM PDT May 7th till 03:03 AM PDT May 7th.

We apologize for the impact and thank you for your patience.
Posted May 07, 2024 - 03:36 PDT
Monitoring
We've implemented the fix and currently monitoring the services.
Posted May 07, 2024 - 03:11 PDT
Investigating
We're experiencing connectivity issues with Login, Launcher and Site Builder services. Some users may face network timeouts.

We're investigating this issue and will post an update shortly.
Posted May 07, 2024 - 02:57 PDT
This incident affected: Login, Launcher, and Site Builder.