Xsolla Login Issue

Incident Report for Xsolla

Resolved

This incident has been resolved.
Posted May 28, 2025 - 03:52 PDT

Update

On May 28, 2025, from 01:11 AM to 02:12 AM PT, our users and partners may have encountered errors in the authentication process due to partial unavailability of the authorization API. Approximately 35% of users were affected during this period.

We sincerely apologize for any inconvenience this may have caused.
Posted May 28, 2025 - 03:50 PDT

Update

We are continuing to monitor for any further issues.
Posted May 28, 2025 - 03:17 PDT

Update

We are continuing to monitor for any further issues.
Posted May 28, 2025 - 03:16 PDT

Monitoring

We've fixed the issue.
We'll monitor the services for the next 10 minutes to ensure stability and will post an update.
Posted May 28, 2025 - 02:18 PDT

Update

We are continuing to work on a fix for this issue.
Posted May 28, 2025 - 02:00 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 28, 2025 - 01:00 PDT
This incident affected: Store, Login, and Site Builder.