Xsolla Login Issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 10, 2018 - 20:09 PDT
Investigating
Temporary technical issues with Xsolla Login from 06:44 PM PST. We apologize for the inconvenience!
Posted 4 months ago. Aug 10, 2018 - 20:04 PDT
This incident affected: Publisher Account.