Xsolla Login Issue
Incident Report for Xsolla
Resolved
We had technical issues with Xsolla Login from 19:48 PM PDT to 20:53 PM PDT..
We've resolved this issue. We apologize for the inconvenience!
Posted 15 days ago. Oct 31, 2018 - 20:55 PDT
Identified
Temporary technical issues with Xsolla Login from 19:48 PM PDT. We apologize for the inconvenience!
Posted 15 days ago. Oct 31, 2018 - 20:43 PDT
This incident affected: Publisher Account.