Payment Processing Issue

Incident Report for Xsolla

Resolved

On July 24, 2026, from 2:15 AM to 2:40 AM PT, the payment creation service was unavailable. During this window, users encountered an error when attempting to initiate a payment.

We sincerely apologize for any inconvenience this may have caused.
Posted Jul 24, 2026 - 02:48 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2026 - 02:41 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 24, 2026 - 02:40 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 24, 2026 - 02:34 PDT

Identified

We're experiencing a partial outage due to issues with payment processing.
Posted Jul 24, 2026 - 02:32 PDT
This incident affected: Pay Station.