Payment Processing Issue
Incident Report for xsolla
Resolved
We had temporary technical issues from 08:19 PM PDT to 08:49 PM PDT. All services are fully operational now. We apologize for the inconvenience!
Posted Oct 18, 2019 - 20:56 PDT
Identified
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2019 - 20:50 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2019 - 20:50 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 18, 2019 - 20:47 PDT
Update
We are continuing to investigate this issue.
Posted Oct 18, 2019 - 20:44 PDT
Update
We are continuing to investigate this issue.
Posted Oct 18, 2019 - 20:35 PDT
Update
We are continuing to investigate this issue.
Posted Oct 18, 2019 - 20:33 PDT
Investigating
We have technical issues with payment processing
Posted Oct 18, 2019 - 20:32 PDT
This incident affected: Pay Station, Store, Login, Launcher, Site Builder, Xsolla.com, Partner Network (Tracking API, Proxy Page), and Services (API, Publisher Account, Documentation).