Xsolla Services Issue

Incident Report for Xsolla

Resolved

On June 24, 2025, from 12:18 AM to 12:26 AM PT, our users may have encountered errors accessing Xsolla services due to temporary network issues with upstream providers.

We sincerely apologize for any inconvenience this may have caused.
Posted Jun 24, 2025 - 01:20 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 24, 2025 - 00:32 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 00:28 PDT
This incident affected: Store and Login.