Payment processing issues
Incident Report for Xsolla
Resolved
We had temporary technical issues with payment processing from 06:16 PM PDT to 6:26 PM PDT
We resolved this issue. We apologize for the inconvenience!
Posted 3 months ago. Aug 27, 2018 - 06:36 PDT
Identified
Partial degradation of the payment processing service is possible.
Posted 3 months ago. Aug 27, 2018 - 06:31 PDT
Investigating
We have technical issues with payment processing
Posted 3 months ago. Aug 27, 2018 - 06:26 PDT
This incident affected: Payment Processing.