Payment processing issues
Incident Report for Xsolla
Postmortem

At 03:59 PM PDT we encountered a technical issue with payment processing service. Our tech team implemented a fix and payment processing service was fully recovered at 04:10 PM. The incident lasted 11 minutes. We apologize for the inconvenience!

Posted 7 months ago. Apr 03, 2019 - 04:56 PDT

Resolved
This incident has been resolved.
Posted 7 months ago. Apr 03, 2019 - 04:44 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Apr 03, 2019 - 04:09 PDT
Investigating
We have temporary technical issues with payment processing
Posted 7 months ago. Apr 03, 2019 - 04:05 PDT
This incident affected: Pay Station and Services (Publisher Account).