Payment Processing Issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 10:59 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2020 - 10:55 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 26, 2020 - 09:17 PDT
Update
We are continuing to investigate this issue.
Posted Mar 26, 2020 - 09:01 PDT
Update
We are continuing to investigate this issue.
Posted Mar 26, 2020 - 09:00 PDT
Investigating
We are currently investigating this issue.
Posted Mar 26, 2020 - 08:59 PDT
This incident affected: Pay Station, Store and Services (API).