Xsolla Login Issue
Incident Report for Xsolla
Resolved
We had technical issues with Xsolla Login from 01:05 PDT May 21th till 01:20 PDT May 21th.

The service is now fully operational. We apologize for any inconvenience this may have caused!
Posted May 21, 2024 - 01:47 PDT
Update
We are continuing to monitor for any further issues.
Posted May 21, 2024 - 01:31 PDT
Monitoring
The issue has been identified and fixed. We're monitoring the situation.
Posted May 21, 2024 - 01:20 PDT
Investigating
We're experiencing technical issues with Xsolla Login.
Posted May 21, 2024 - 01:05 PDT
This incident affected: Login.