Payment Processing Issue
Incident Report for Xsolla
Postmortem

There were temporary technical issues with Payment Gateways from 23:33 PST until 23:42 PST on February 20 that delayed the processing of payments. Currently all services are fully operational. Thank you for your patience!

Posted Feb 21, 2020 - 00:30 PST

Resolved
This incident has been resolved.
Posted Feb 20, 2020 - 23:47 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2020 - 23:44 PST
Investigating
We're experiencing a partial outage due to issues with payment processing.
Posted Feb 20, 2020 - 23:40 PST
This incident affected: Pay Station.