Payment Processing Issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted Jul 10, 2020 - 09:39 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2020 - 09:34 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 10, 2020 - 09:09 PDT
This incident affected: Pay Station.