Payment Processing Issue
Incident Report for xsolla
Resolved
We had temporary technical issues from a 5/20/2021 05:22 AM PST to 5:53 AM PST. All services are fully operational now. We apologize for the inconvenience!
Posted May 20, 2021 - 08:11 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2021 - 06:57 PDT
Investigating
We're experiencing a partial outage due to issues with payment processing.
Posted May 20, 2021 - 06:30 PDT
This incident affected: Pay Station and Services (API).