Network connectivity issues

Incident Report for Xsolla

Resolved

From 2025-03-02 16:02 PST to 2025-03-02 16:21 PST, users may have experienced increased latency, causing delays in application responses. Network latency has now returned to normal levels, and we are not observing any issues within our infrastructure. We requested information from our backbone providers regarding any potential external incidents.
Posted Mar 02, 2025 - 16:44 PST

Investigating

Increased latency and intermittent network disconnections observed in network traffic, causing delays in application responses. The network team is analyzing the issue.
Posted Mar 02, 2025 - 16:21 PST
This incident affected: Pay Station, Store, Login, and Xsolla.com.