Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2025 - 22:00 PST
Update
Please note that the maintenance window has been rescheduled. The new maintenance period will take place from 10:00 PM on November 12 to 2:00 AM on November 13 (Pacific Time).
If you have any questions or need assistance, please contact your Customer Success Manager or Xsolla Support.
Thank you for your continued partnership, The Xsolla Team
Posted Nov 03, 2025 - 20:22 PST
Update
Please note that the maintenance window has been rescheduled. The new maintenance period will take place from 10:00 PM on November 5 to 2:00 AM on November 6 (Pacific Time).
If you have any questions or need assistance, please contact your Customer Success Manager or Xsolla Support.
Thank you for your continued partnership, The Xsolla Team
Posted Oct 28, 2025 - 09:27 PDT
Scheduled
To continue improving the performance, stability, and resilience of Xsolla’s infrastructure, we will be conducting scheduled maintenance during the following window (Pacific Time): Start: Wednesday, November 12, 10:00 PM End: Thursday, November 13, 2:00 AM
What to Expect During this period, there may be brief interruptions in service — up to 30 minutes total, distributed across the maintenance window: - Approximately 15 minutes affecting all Xsolla systems. - Approximately 15 minutes affecting In-Game Store services specifically. As part of this update, we will also perform key operations to update and validate our resilience and ensure uninterrupted reliability in the future. Our teams will be actively monitoring the process and working to keep any disruption as short as possible.
We appreciate your patience and understanding as we continue to make Xsolla’s systems stronger and more dependable.
If you have any questions or need assistance, please contact your Customer Success Manager or Xsolla Support.
Thank you for your continued partnership, The Xsolla Team
Posted Oct 23, 2025 - 15:19 PDT
This scheduled maintenance affected: Pay Station, Store, Login, Launcher, Site Builder, Xsolla.com, Partner Network (Tracking API, Proxy Page), and Services (API, Publisher Account, Documentation).