Launcher issue
Incident Report for xsolla
Resolved
We had temporary issues with downloading games and their updates in the Launcher from a 12/15/2021 7:21 AM PST to 7:48 AM PST. All services are fully operational now. We apologize for the inconvenience!
Posted Dec 15, 2021 - 10:02 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2021 - 08:41 PST
Update
At this moment, there may be problems with downloading games and their updates in the launcher. This is due to problems with amazon s3. We are working on possible solutions from our side in case of long-term problems on the Amazon side.
Posted Dec 15, 2021 - 08:20 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 15, 2021 - 08:17 PST
Investigating
We are currently investigating this issue.
Posted Dec 15, 2021 - 08:02 PST
This incident affected: Launcher.