Xsolla Login Issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted Apr 06, 2020 - 05:23 PDT
Investigating
We're experiencing technical issues with Xsolla Login.
Posted Apr 06, 2020 - 05:12 PDT
This incident affected: Login and Launcher.