Payment processing issues
Incident Report for Xsolla
Resolved
We had temporary technical issues with payment processing from 03:37 PM PST to 5:00 PM PST
We resolved this issue. We apologize for the inconvenience!
Posted 3 months ago. Aug 15, 2018 - 18:12 PDT
Identified
Partial degradation of the payment processing service is possible. We are currently investigating this issue.
Posted 3 months ago. Aug 15, 2018 - 17:46 PDT
Investigating
We have technical issues with payment processing from 03:37 PM PST
Posted 3 months ago. Aug 15, 2018 - 17:40 PDT
This incident affected: Payment Processing.