Payment processing issue
Incident Report for xsolla
Postmortem

At 10:12 PM PST we encountered a technical issue with new version of Payment UI. Our tech team implemented a fix and payment processing service was fully recovered at 10:26 PM. The incident lasted 14 minutes. We apologize for the inconvenience!

Posted Nov 22, 2017 - 23:29 PST

Resolved
This incident has been resolved.
Posted Nov 22, 2017 - 22:35 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2017 - 22:29 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 22, 2017 - 22:26 PST
Investigating
We are currently investigating this issue.
Posted Nov 22, 2017 - 22:24 PST