Network issue
Incident Report for Xsolla
Resolved
The issue with launcher.xsolla.com and login.xsolla.com has been resolved.
Posted 5 months ago. Jul 17, 2018 - 13:28 PDT
Identified
The issue with launcher.xsolla.com and login.xsolla.com has been identified.
Posted 5 months ago. Jul 17, 2018 - 13:13 PDT
Investigating
Unfortunately, we are experiencing some network issues. Thanks for your patience!
Posted 5 months ago. Jul 17, 2018 - 12:52 PDT