Xsolla Login Issue
Incident Report for Xsolla
Resolved
The service is fully operational now. We apologize for the inconvenience!
Posted 17 days ago. Jun 02, 2019 - 16:18 PDT
Update
We are continuing to work on a fix for this issue.
Posted 17 days ago. Jun 02, 2019 - 15:55 PDT
Update
We are continuing to work on a fix for this issue.
Posted 17 days ago. Jun 02, 2019 - 13:50 PDT
Update
We currently have issues with the availability of our google cloud services

https://status.cloud.google.com/incident/cloud-networking/19009
Posted 17 days ago. Jun 02, 2019 - 13:35 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 17 days ago. Jun 02, 2019 - 12:41 PDT
Investigating
We're experiencing technical issues with Xsolla Login.
Posted 17 days ago. Jun 02, 2019 - 12:25 PDT
This incident affected: Services (Publisher Account) and Login, Launcher.