Payment processing issues
Incident Report for Xsolla
Postmortem

At 03:47 AM PDT we encountered a technical issue with new version of Payment UI. Our tech team implemented a fix and payment processing service was fully recovered at 03:54 AM. The incident lasted 7 minutes. We apologize for the inconvenience!

Posted 3 months ago. May 04, 2018 - 04:02 PDT

Resolved
This incident has been resolved.
Posted 3 months ago. May 04, 2018 - 03:58 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. May 04, 2018 - 03:54 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. May 04, 2018 - 03:53 PDT
This incident affected: Payment Processing.