Payment processing issues
Incident Report for Xsolla
Resolved
We had temporary technical issues with payment processing from 05:47 PM PDT to 5:43 PM PDT
We resolved this issue. We apologize for the inconvenience
Posted 2 months ago. Oct 12, 2018 - 05:50 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Oct 12, 2018 - 05:47 PDT
Identified
Partial degradation of the payment processing service is possible.
Posted 2 months ago. Oct 12, 2018 - 05:44 PDT
Investigating
We have technical issues with payment processing from 05:37 PM PDT
Posted 2 months ago. Oct 12, 2018 - 05:43 PDT
This incident affected: Payment Processing.