Payment processing issues
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 12, 2018 - 01:34 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. Jan 11, 2018 - 23:46 PST
Investigating
We are currently investigating this issue.
Posted 5 months ago. Jan 11, 2018 - 23:43 PST