Xsolla Login Issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 23, 2018 - 02:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Jul 23, 2018 - 02:20 PDT
Investigating
Temporary technical issues with Xsolla Login from 11:05 PM PDT. We apologize for the inconvenience!
Posted 5 months ago. Jul 22, 2018 - 23:44 PDT