Payment processing issues
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted 21 days ago. Nov 21, 2018 - 00:50 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 21 days ago. Nov 21, 2018 - 00:41 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 21 days ago. Nov 21, 2018 - 00:39 PST
Investigating
We have technical issues with payment processing from 12:44 AM PDT
Posted 21 days ago. Nov 21, 2018 - 00:37 PST
This incident affected: Payment Processing.