Publisher Account Issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 20, 2018 - 10:26 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. Jul 20, 2018 - 06:32 PDT
Investigating
Temporary technical issues with Publisher Account from 6:06 AM PDT. We apologize for the inconvenience!
Posted 5 months ago. Jul 20, 2018 - 06:31 PDT
This incident affected: Publisher Account.