Payment Gateway issue
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 12, 2018 - 04:30 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 8 months ago. Mar 12, 2018 - 01:40 PDT
Investigating
We are currently investigating this issue.
Posted 8 months ago. Mar 12, 2018 - 01:21 PDT