Payment processing issues
Incident Report for Xsolla
Resolved
We had technical issues with payment processing from 6:55 AM PST to 9:15 AM PST.
We've resolved this issue. We apologize for the inconvenience!
Posted 5 months ago. Feb 22, 2018 - 09:28 PST
Investigating
We have technical issues with payment processing. We are currently investigating this issue.
Posted 5 months ago. Feb 22, 2018 - 07:47 PST