Payment processing issues
Incident Report for Xsolla
Resolved
We had technical issues with payment processing from 4:55 PM PST to 5:40 PM PST.
We've resolved this issue. We apologize for the inconvenience!
Posted 2 months ago. Mar 06, 2018 - 17:48 PST
Investigating
We have technical issues with payment processing. We are currently investigating this issue.
Posted 2 months ago. Mar 06, 2018 - 17:29 PST