Technical issues
Incident Report for Xsolla
Resolved
We had technical issues with payment processing from 7:59 PM to 9:10 PM PST.
We've resolved this issue. We apologize for the inconvenience!
Posted 5 months ago. Feb 20, 2017 - 21:29 PST
Investigating
We have technical issues with payment processing from 7:59 PM PST
Posted 5 months ago. Feb 20, 2017 - 21:06 PST