Payment processing issues
Incident Report for Xsolla
Resolved
This incident has been resolved.
Posted 18 days ago. May 01, 2018 - 22:13 PDT
Update
We had technical issues with payment processing from 02:29 AM PDT to 02:49 AM PDT.
We've resolved this issue. We apologize for the inconvenience!
Posted 18 days ago. May 01, 2018 - 22:12 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 19 days ago. May 01, 2018 - 04:34 PDT
Identified
We have technical issues with payment processing from 02:29 AM PDT
Posted 19 days ago. May 01, 2018 - 03:43 PDT
This incident affected: Payment Processing.