Payment processing issues
Incident Report for Xsolla
Resolved
Approximately from 05:30 PM to 10:00 PM PDT there was an issue with the list of available payment methods. Most of the problems started around 08:00 PM to 10:00 PM PDT.
Also, during maintenance a 2 minute outage took place. Currently, the service is operating normally. We apologize for any inconvenience.
Posted 12 months ago. Jul 04, 2016 - 22:30 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 12 months ago. Jul 04, 2016 - 21:49 PDT
Investigating
Currently we are experiencing technical issues with paystation availability. Our specialists are currently investigating the isssue, paystation should be available in the nearest time. We are apologize for all the inconveniences.
Posted 12 months ago. Jul 04, 2016 - 20:53 PDT